Swat 4 Access Violation caused General protection fault!

15 posts / 0 new
Last post
Prisoner416
Offline
Last seen: 1 year 9 months ago
Swat 4 Access Violation caused General protection fault!

With Swat 4 Gold, I keep crashing when trying to load various missions/maps with a "Access Violation caused General protection fault!" error. Any ideas on how to solve it? I know I used to be able to play the game on Win7 x64 before...

SAS_DeCapi
Lieutenant Colonel
Lieutenant Colonel
SAS_DeCapi's picture
Online
Last seen: 4 min 45 sec ago

Take a look at http://answers.yahoo.com/question/index?qid=20090414111656AALJyiL

SAS_LtCol_DeCapi 
Commanding Officer

GCHQ
22nd [SAS] Elite Virtual Regiment

SAS_WIZ
Veteran
Veteran
Offline
Last seen: 5 months 4 weeks ago

Run it in xp compatibility mode with admin privs Wink

SAS_WIZ

Prisoner416
Offline
Last seen: 1 year 9 months ago

Oddly enough, everything runs fine until I patch the game and install the expansion pack.

I'll do more tweaking tomorrow and see if the compat. install works.

Prisoner416
Offline
Last seen: 1 year 9 months ago

How ironic. It seems the patch for the game is actually causing the problem. All tests seem to indicate that once the Game Engine files are "upgraded", certain maps simply crash during load.

Since I can't install the Expansion without patching the game, and I really don't want to go through the hassle of rolling back drivers to see if it MIGHT fix it, I guess I'll be stuck with the original.

SAS_WIZ
Veteran
Veteran
Offline
Last seen: 5 months 4 weeks ago

did you allow it to install directx 9?

SAS_WIZ

SAS_DUKE
Veteran
Veteran
Offline
Last seen: 5 years 5 months ago

Is it right that you try to patch SWAT 4 from version 1.0 to version 1.1 Question

I really can't remember that I ever have patched the original SWAT 4. Just checked the serverlist - every server is running version 1.0. Deinstall game, then see below instruction. Maybe this helps.

As general info: If you buy the goldpack (SWAT 4 + Expansion TSS), you have to do it this way to get it running:

1. Install SWAT 4
2. Run the game once Exclaim
3. Install Expansion TSS

"What's the plan?
Track'em, find'em, kill'em!"

SAS_Walker
Trooper
Trooper
SAS_Walker's picture
Offline
Last seen: 1 month 3 days ago

The patch is for Swat 4 only. You have to install the patch in order to play TSS. So at the end you will have SWAT 4 ver 1.1 and SWAT 4 TSS ver 1.0. If you start the server browser for SWAT 4 (not TSS) then you will see most servers 1.1 patched.

SAS_Walker
22nd [SAS] Elite Virtual Regiment

SAS_WIZ
Veteran
Veteran
Offline
Last seen: 5 months 4 weeks ago

Tss is by default, 1.1

SAS_WIZ

Prisoner416
Offline
Last seen: 1 year 9 months ago

No Label

Crash Time: 09/28/12 20:43:57

OS: Windows NT 6.1 (Build: 7601)
CPU: AuthenticAMD Unknown processor @ 3216 MHz with 4095MB RAM
Video: NVIDIA GeForce 9600 GSO (623)

UserName: DoctorWho
ComputerName: TARDIS
Application location: C:\Program Files (x86)\Sierra\SWAT 4\Content\System\

SWAT Build Number: 34688

Access Violation caused General protection fault!

History: UGameEngine::Tick GenerateExtraCrashInfo [(GLevel: 'myLevel' PendingLevel: '(NULL)' NetMode: 'NM_Standalone']

Going to try rolling back drivers at this point.

Prisoner416
Offline
Last seen: 1 year 9 months ago

Well, solved part of the problem.

Using GameBooster allows the game to work, so it seems some background task or service was mucking things up. I will try to see if I can narrow down which one.

Except, now the internet game servers aren't listed.

Boo.

Also, is there any way to play the original missions inside of the expansion pack so that the new weapons can be used?

SAS_MM18
Lance Corporal
Lance Corporal
SAS_MM18's picture
Offline
Last seen: 27 min 19 sec ago

The easiest way is to create a custom mission and set all settings to the ones used during the campaign.

The other way that should work (have tried it successfully on custom maps) is loading the map in the console using the "open" command, you just need to know the name of the map file (the "SP-" map files are located in the "maps" folder, located within the "content" folder of your swat installation) and type "open mapname" (replace appropriately) in the console. Drawbacks to this alternative are that you don't get to choose equipment before going in, you go with what you used last time; and you can't select an entry point afaik.

As for the server list not appearing, we're all on the edge of our seats waiting for the resolution of that one.
http://www.sasclan.org/modules.php?name=Forums&file=viewtopic&t=11028

Prisoner416
Offline
Last seen: 1 year 9 months ago

Well... darn and double darn.

I have the SAS map pack v2, and I'd hate to have to print out all the map names for console use. Really wish they had a simple file scanner to detect and add plug-ins. Unless I'm missing something and there is an easier way. Forgive me, literally just got the game weeks ago after deciding to expand a bit from R63.

Also, at least I know the server issue isn't just my problem. I knew I had it working earlier this week.

SAS_Random
Veteran
Veteran
SAS_Random's picture
Offline
Last seen: 4 days 8 min ago

Pick a map that's crashing and copy it to the other map folder. If you have an expansion map and want to play it in original swat, copy it to swat maps folder. The file extensions are the same, so it should work.

SAS_Vet_Random

Lt. Col (Retired)

22nd [SAS] Elite Virtual Regiment

 

 

Prisoner416
Offline
Last seen: 1 year 9 months ago

Pick a map that's crashing and copy it to the other map folder. If you have an expansion map and want to play it in original swat, copy it to swat maps folder. The file extensions are the same, so it should work.

Already fixed the crashing issue, but thanks!