Swat4 crashing

7 posts / 0 new
Last post
officer_allen
Offline
Last seen: 10 years 4 months ago
Swat4 crashing

Well Gents looks like i have a problem. Dont ko exactly what it is but hopefully u guys will... If you could give me sum infoo on this it would be nice. Below is a copy of what appears in box when i crash didnt kno if u would need it in order to identify my problem...

No Label

Crash Time: 06/07/08 07:58:09

OS: Windows NT 6.0 (Build: 6001)
CPU: GenuineIntel PentiumPro-class processor @ 1600 MHz with 2038MB RAM
Video: Intel(R) 82945G Express Chipset Family (1409)

UserName: shatara
ComputerName: SHATARAPC
Application location: C:\Program Files\Sierra\SWAT 4\ContentExpansion\System\

SWAT Build Number: 1.0

ReadFile failed: Count=0 BufferCount=-36924462 Error=Invalid access to memory location.

History: FCompactIndexGenerateExtraCrashInfo [(GLevel: 'myLevel' PendingLevel: '(NULL)' NetMode: 'NM_Standalone']

Timbo
Offline
Last seen: 8 years 9 months ago

this error message:
"ReadFile failed: Count=0 BufferCount=-36924462 Error=Invalid access to memory location. "
is a php error in same cases lol but not here...
i guess this is the known microsoft windows error message when a 32bit windows system tries to logon to a 64bit windows server and the application calls the LsaLogonUser. I dont know how the logon precedure is set for Swat, but for this there is a official windows patch.
http://support.microsoft.com/kb/833620/en-us
but I would suggest that you reinstall swat first, before using the hotfix. Save your user.ini file and your maps first, then deinstall and reinstall swat. If the problem still occurs -> try the hotfix

-Timbo out

officer_allen
Offline
Last seen: 10 years 4 months ago

i will go do right now thnx Timbo BiggrinBiggrinBiggrin

officer_allen
Offline
Last seen: 10 years 4 months ago

sorry bud it still doesnt work now its says error code 40. so i deleted what u told em to install and re installed(again) and it still crashes. QuestionQuestion hope i didnt confuse u there bro.

Spidey01
Offline
Last seen: 3 months 1 week ago

"ReadFile failed: Count=0 BufferCount=-36924462 Error=Invalid access to memory location. "

To me this sounds like the game is probably trying to dereference a null or wild pointer, that is assumed to be valid.

(Programmer Error, not Program Error)

The history thing is what passes for a backtrace when the game crashes. It seems to die while trying to start the game, it's referencing a map load so I have to ask:

Have you (or anyone else) been playing around in SwatEd (the map maker) and what are the contents of \Sierra\SWAT4\Content\Maps and \Sierra\SWAT4\ContentExpansion\Maps.

I recall getting map load related crashes on game startup if I ever use the editor to test play a map Beee

Reinstalling the games would likely fix it either way.

officer_allen
Offline
Last seen: 10 years 4 months ago

I tried to add a map last night to content expansio/maps but once it dowloaded it did not work so I deleted it out of the maps folder.

officer_allen
Offline
Last seen: 10 years 4 months ago

Im back on...Thanx for the Help i figured it out..