SWAT 4 Expansion problem

13 posts / 0 new
Last post
Vyro
Offline
Last seen: 12 years 2 months ago
SWAT 4 Expansion problem

HI, well i was told by [SAS]Blade that the gold pack has both swat 4 and TSSm i got it , went home and the expansion doesnt work at all...swat runs fine, but when i try runing TSS it freezes on a black screen, just wondering if anyone could help me solve this problem, any help would be great, thanks... :frown:

Rand
Offline
Last seen: 12 years 6 months ago

Try updating your drivers.

only those who will IMAGE(http://miniprofile.xfire.com/bg/co/type/2/sasrand.png)

Vyro
Offline
Last seen: 12 years 2 months ago

they are updated tho :embarassed:

SAS_Shield
Veteran
Veteran
Offline
Last seen: 8 years 2 months ago

black screen usually indicates a videocard conflict so if you are sure and have checked recently that the drivers are up-to-date maybe your card dosnt support the expansion for some reason? i doubt that, what kind is it? have you tried contacting support?

"Game over man." Pvt. Hudson. SAS 22nd E.V.R.

Vyro
Offline
Last seen: 12 years 2 months ago

well Ill get u a list of what i got

P4ht 3.0GHZ
512DDR ram
ATI RADEON 9200SE 128MB

u know what, when i updated my driver, catalyst 6.4 it said NO SERVICE ERROR, could that be a problem or is that just saying the driver is already updated to 6.4?

i donno i contacted the company, so we'll see, but any more help would be really great :eek: thank you for even reading lol Blum 3

SAS_WIZ
Veteran
Veteran
Offline
Last seen: 5 months 3 weeks ago

it is quite normal in SWAT4 to see a black screen for upto 5mins.
Try closing a lot of sub-programs, to speed this up.

SAS_WIZ

Rand
Offline
Last seen: 12 years 6 months ago

Cat Uninstaller: found here:
https://support.ati.com/ics/support/default.asp?deptID=894&task=knowledge&folderID=27
go down to Utilities,
then Various,
then CATALYST - ATI Maintenance Utilities,
then cat-uninstaller.exe
Would not allow direct links, or would have just posted it.

Quoted from :
http://www.savagenews.com/forums/index.php?showtopic=39

The problem you are encountering probably stems from the conflict which the system experiences while trying to assign a new driver to your card. To prevent such conflict, ensure you remove the drivers of previous graphic cards or versions of ati drivers COMPLETELY. To do that, I would advise that you download specific uninstalling utilities from the graphic card vendor or driver provider rather than relying on third party software or manual removal which is extremely risky.

I had the same problem once, but mine occurred while I was trying to reinstall the driver after I had removed the card to do some tweaking. For your info, I was using gigabyte's R9600 pro card then.

It was certainly baffling as I had no problems at all when I first installed the driver after I bought the card. So it was unlikely that the driver was in conflict with the card or my xp os. Anyway, I diligently uninstalled the driver from add/remove and cleared my system of all ATI related stuff but the problem just doesn't go away.

Finally I downloaded the cat-uninstaller utility from ati website(below),

https://support.ati.com/ics/support/default...dge&folderID=27

which was more capable of doing a thorough cleanup. For better results, use the program while you are in safe mode since you can be sure that ati drivers will not be loaded or used. Reboot the computer and installling any driver should now be a breeze.....

only those who will IMAGE(http://miniprofile.xfire.com/bg/co/type/2/sasrand.png)

Vyro
Offline
Last seen: 12 years 2 months ago

yea still no go, i replaced the game at the future shop store, hopefully it was a cd problem, if not im screwed :ohwell: damn lol...but lets hope it works, if u guys come up with any more suggestions in helping me with this problem i would be mnuch greateful, thank you for all the help so far... :eek:

SAS_Dave
Veteran
Veteran
Offline
Last seen: 8 years 3 months ago

That´s a problem with Swat 4 TSS (as well as the crash problem). I have big loading times too but after about 5 mins the game starts.
I can´t connect to any servers online though.

Sux. But the game is awesome (in SP)

'When I want your opinion, I'll beat it out of you.' --- 37% of Americans agree that while they would hate being British, they wouldn't mind having a British accent. --- Ever stop to think, and forget to start again?

Smoothies
Offline
Last seen: 12 years 6 days ago
Re: SWAT 4 Expansion problem

HI, well i was told by [SAS]Blade that the gold pack has both swat 4 and TSSm i got it , went home and the expansion doesnt work at all...swat runs fine, but when i try runing TSS it freezes on a black screen, just wondering if anyone could help me solve this problem, any help would be great, thanks... :frown:

There is a friend of mine who has this same problem and it resolves around the fact if your graphics card is supported or not. Please check to see if your graphics card is supported by the expansion first (the only cards known to work will be listed on the bottom of the box). If your card is not listed then the game simply won't work propperly or not at all since there's no offical support for your graphics card by either the studio or the card manufacture's currently installed driver. If you do have a supported card then you may have to do one of the following:

1. Update your graphics driver

2. Downgrade your graphics driver

If you're unsure about what driver you're using for your card you can check by going to from the start menu:

settings > control panel > Display

From there click on the Settings tab and then click on the Advanced button. Here you can edit monitor options and access your graphic card's options. If you use ATI, you should click on the Catalyst Control center and follow the directions there (which will take you to the Control Center's program which will tell you what Catalyst verison you have). Nvidia should be a bit more of the same but everything (unless they changed everything around to mimic ATi) will be under the current Advanced options widow you're accessing.

Here are the two comapnies' websites:

http://www.ati.com

http://www.nvidia.com

From one of those download the driver for your make and model for your video card for your operation system. If you use Windows XP and have an ATi Radeon card make sure you get the Catalyst driver for Radeons on the XP list. I've dealt wtih people who snagged the FireGL or CrossFIre drivers for their x600 Radeons before at LANs and have questioned why the hardware works incorrectly.

If you have the latest driver, then you should downgrade to one or two verisons older and try the game again. If you get black screen of death still, then either the graphics card manufacturer hasn't fixed rendering errors the drivers are having with the title or the game studio itself didn't give support to the card.

IMAGE(http://card.mygamercard.net/gbar/Confused+Gunman.gif)

Never trust a hermit with your cookie.

SAS_WIZ
Veteran
Veteran
Offline
Last seen: 5 months 3 weeks ago

from the SWAT4 Tss Readme.ini:

AMD64® Processors and Nvidia® video cards
-Users of AMD64® Processors and Nvidia® video cards may experience issues upon exiting
SWAT 4. These issues are the result of a known fault within the Nvidia® drivers.
Upgrading your Nvidia® drivers to version 71.89 or better will correct this problem.

Black Screen seen while loading
-SWAT 4 - The Stetchkov Syndicate might take some time to load so you might see a
black screen or loading screen for some time. Please be patient and let the game load for
some time. Depending on your computer specifications it might take a few seconds or a few
minutes for PC's near to or below the minimum system requirements.

SAS_WIZ

Vyro
Offline
Last seen: 12 years 2 months ago

HEY EVERYONE!!! I FOUND A WAY TO FIX THIS BLACK SCREEN PROBLEM, here is what you do...

1) Launch Swat 4 TSS
2) Let the black screen be there for 5 seconds
3) After seeing the black screen for 5 secs start hitting the ESC key
4) WHen the game goes to the desktop go back into the game..and there, it works!!!

SAS_En4cer
Veteran
Veteran
Offline
Last seen: 6 years 7 months ago

Good find Vyro... lets hope it works for others too !

[color=yellow][SAS] 22nd E.V.R. - SAS_VET_EN4CER /[color] Virtus Disciplina Unitas