RavenShield Server Lag -- A Couple of tweaks to reduce it.

22 posts / 0 new
Last post
SAS_WIZ
Veteran
Veteran
Offline
Last seen: 4 months 4 weeks ago
RavenShield Server Lag -- A Couple of tweaks to reduce it.

If you are experiencing lag on server there are some things that you can do to help. First off, you will need to know a couple of numbers.
You will need to know a rough average speed that you normally download files at, in kb/s. Secondly you will need to know your FPS (frames per second). Whilst playing in the server, open up the console and type FPS into it, your FPS will then be displayed on the screen.

Now that we have those 2 vital pieces of information. We need to find and open your RavenShield.ini file, Normally located:
C:\\program files\Red Storm Entertainment\RavenShield\system\RavenShield.ini

And find the following (highlighted) lines:

IMAGE(http://img693.imageshack.us/img693/5944/rvsini.gif)

Ok..Heres where those numbers come in. First off the MinDesiredFrameRate, this as we see here is set to 10, this is bad for business straight away, Ill explain why....
RavenShield has the ability to dynamically adjust what information it loads, depending on your FPS...This means that, in this case, it will allow your FPS to drop all the way down to 10 frames per second, before the game starts dynamically compensating to keep you playing...So go ahead, change this to 35, which is a good starting point (mine is 50 because i get a constant 60fps). Now your machine will start dumping little things to keep the game playing at full speed, only if the FPS drops below 35.

Next we have ConfiguredInternetSpeed. This is where your download rate comes into play. By default it is set to 20,000; also bad for business, as this is the ideal number for a T1/Lan connection.
For a slow connection (56k narrowband modem) a setting of 2800 is ideal. For normal ADSL a setting of 10000 is just peachy. I recommend starting at 10,000 either way, and see how it goes.

Go ahead, play around with those figures...If you have no problems, turn them up, if its better but still slow...turn them down.

Hope you enjoyed this tutorial.

SAS_WIZ

SAS_Random
Veteran
Veteran
SAS_Random's picture
Offline
Last seen: 3 days 26 min ago

nice stuff!!

SAS_Vet_Random

Lt. Col (Retired)

22nd [SAS] Elite Virtual Regiment

 

 

SAS_WIZ
Veteran
Veteran
Offline
Last seen: 4 months 4 weeks ago

Just for some further information, these 2 tweaks should not be picked up by Punkbuster or Sentinel anti-cheat software; as it is only a configuration tweak; and not a mod.

Also, I would not recommend playing with the other settings, unless you really know what you are doing. That counts me out then Wink

SAS_WIZ

Spidey01
Offline
Last seen: 2 months 1 week ago

It's worth noting that Raven Shield will occasionally reset that Engine.Player.ConfiguredInternetSpeed value to one of the games built in settings (which are totally wrong for most people today). This is particularly a problem with RvS more so than SWAT 4.

If you find yourself getting heavier lag a few weeks later, check the setting again. You can use the "stat net" and "netspeed XXXXXX" commands in console to toggle viewing and setting it; where XXXXXX is a number.

SAS_WIZ
Veteran
Veteran
Offline
Last seen: 4 months 4 weeks ago

where netspeed would be the 20000 in my diagram..so just type 'netspeed YOUR TWEAKED FIGURE'

SAS_WIZ

Cougar
Offline
Last seen: 3 years 1 week ago

I get an "access denied" message when I try to save and replace the file after changing the settings. Anyone?

Windows 7

IMAGE(http://miniprofile.xfire.com/bg/sh/type/0/slack911.png) aka Slack911, yamaraion, M827_CSM_COUGAR,Cougar]

SAS_Random
Veteran
Veteran
SAS_Random's picture
Offline
Last seen: 3 days 26 min ago

are you changing netspeed from the game's console or from your program folder?

If from the program folder, you may need to have the game closed.
The netspeed command should work for you from the console if you still can't access the program folder you need.

SAS_Vet_Random

Lt. Col (Retired)

22nd [SAS] Elite Virtual Regiment

 

 

SAS_WIZ
Veteran
Veteran
Offline
Last seen: 4 months 4 weeks ago

right click on your ravenshield folder, and click 'properties' then the 'security' tab. then highlight your username and click 'edit' then highlight your username again and tick the 'full control' box..save it all and your edits will save

SAS_WIZ

Cougar
Offline
Last seen: 3 years 1 week ago

Ty, sorry I didn't make another post. I figured out it was that it didn't recognize me as admin and changed the Properties >> security. Win 7 drives me nuts sometimes...ok, most of the time.

Now if I can just get it to save my gamma settings so I do not have to set them every time i enter a server..

IMAGE(http://miniprofile.xfire.com/bg/sh/type/0/slack911.png) aka Slack911, yamaraion, M827_CSM_COUGAR,Cougar]

SAS_WIZ
Veteran
Veteran
Offline
Last seen: 4 months 4 weeks ago

Yer, Win7 can be an absolute pain for read/write permissions

SAS_WIZ

SAS_WIZ
Veteran
Veteran
Offline
Last seen: 4 months 4 weeks ago

post restored from the archives and stickied Wink

SAS_WIZ

Lodige
Lodige's picture
Offline
Last seen: 2 years 4 months ago

thx wiz very helpfull Smile
what should we do without u Sir

Prisoner416
Offline
Last seen: 1 year 8 months ago

If you are running the game on steam, the directory is C:\Program Files (x86)\Steam\steamapps\common\rainbow six 3 gold on Windows 7 x64.

Any 64 bit system will have the files in the x86 folder as well.

SAS_Ezbass
Veteran
Veteran
Offline
Last seen: 5 years 9 months ago

Thanks Sir.

Rainbow_Unit
Offline
Last seen: 5 years 7 months ago

This post is useful, I might try it one day Smile depending how it goes, I just got my Network upgraded hopefully Less lags than before Smile

SAS_Master
Regimental Sergeant Major
Regimental Sergeant Major
SAS_Master's picture
Offline
Last seen: 11 min 18 sec ago

I can't find any conclusive material on this via the power of google, so I might as well post here.

One of my biggest annoyances with RVS is that fact that if I'm slicing the pie around a corner, tangos will just 'pop' up from thin air as their bodies get instantly rendered the second I'm in their fireline.

Are there any known fixes for this rather annoying rendering problem or is it an internet connection thing? I admittedly don't get this in singleplayer.

SAS_Master - Regimental Sergeant Major

GCHQ

"He's trusting you to do your job which is to clear that corner! Nothing else!"

SAS_WIZ
Veteran
Veteran
Offline
Last seen: 4 months 4 weeks ago

Sounds like a buggy connection to me, or/and you have something running in the background thats eating your ram ~ ie it is rendering but your computer is stuttering, so it just appears.

SAS_WIZ

SAS_Master
Regimental Sergeant Major
Regimental Sergeant Major
SAS_Master's picture
Offline
Last seen: 11 min 18 sec ago

I think I'll try fiddling around with the connection speed tweaks and see if that does anything. I've got 3 gigs of system RAM and then a further 1 gig of ram on my graphics card, so I doubt it'd be a process chewing through loads of my ram and/or CPU, as this problem doesn't appear in singleplayer (if i recall correctly).

Interestingly though, the guns seem to 'always' be rendered, so I could see a floating gun sometimes and then suddenly a tango pops out of thin air holding said gun.

SAS_Master - Regimental Sergeant Major

GCHQ

"He's trusting you to do your job which is to clear that corner! Nothing else!"

SAS_Master
Regimental Sergeant Major
Regimental Sergeant Major
SAS_Master's picture
Offline
Last seen: 11 min 18 sec ago

Ok, I've got a quick video of this problem:

http://www.xfire.com/video/6026ca

I'm guessing buggy connection to the server might be the reason for the jitter and the glitchy tangos.. I'll try a few other servers of similar ping (125-140) and see how it goes. Tried setting the internetspeed to both 10000 and 20000, did nothing to help either.

SAS_Master - Regimental Sergeant Major

GCHQ

"He's trusting you to do your job which is to clear that corner! Nothing else!"

SAS_WIZ
Veteran
Veteran
Offline
Last seen: 4 months 4 weeks ago

If you are talking about the guy in the toilet..thats a mapping issue Rvs has always glitched on that tango due to the way it handles the 'zones' and rendering

SAS_WIZ

SAS_Master
Regimental Sergeant Major
Regimental Sergeant Major
SAS_Master's picture
Offline
Last seen: 11 min 18 sec ago

Yeah, thing about the toilet tango is that online, it rather regularly happens even when I'm, say, pieing a room or corner. They sometimes just don't render until a split second after they've seen me, which results in a predictable 'alaaaaarm!' *splat i'm dead*.

Another, probably related issue is the general shudderiness (see around 0:06-0:10 as I appear to lag or something) ingame when moving, I'm 99% sure this is a connection problem to the server as I don't get any kind of shudderiness in singleplayer.

Admittedly my ping is listed as around 125-140 ingame.. But man, I don't get that kind of crazy performance in Swat 4, so it's quite annoying!

SAS_Master - Regimental Sergeant Major

GCHQ

"He's trusting you to do your job which is to clear that corner! Nothing else!"

Elite_
Offline
Last seen: 5 years 2 months ago

Same here... I have also synchronization problems.