Problem with mouse

16 posts / 0 new
Last post
Cougar
Offline
Last seen: 3 years 1 month ago
Problem with mouse

Apparently I was the victim of a lightning strike today, mid-mission. When I reset the UPS and logged back onto RvS, all my settings were gone. I was even "Player" instead of "John Doe". After resetting my controls in Options, I rejoined the game on PG1. I could chat and load into the game, switch weapons, but absolutely no movement occurred due to keys or mouse input and weapons would not fire. Yet, before going in-mission, my mouse works normally and after leaving mission it works normally.

Any ideas? Question

IMAGE(http://miniprofile.xfire.com/bg/sh/type/0/slack911.png) aka Slack911, yamaraion, M827_CSM_COUGAR,Cougar]

Cougar
Offline
Last seen: 3 years 1 month ago

I've :cry: pretty much determines that I have to uninstall/reinstall RvS. I think I have a corrupted file. I get the same problem with a ball-mouse and no other game has this problem.

IMAGE(http://miniprofile.xfire.com/bg/sh/type/0/slack911.png) aka Slack911, yamaraion, M827_CSM_COUGAR,Cougar]

Grishenko
Offline
Last seen: 8 years 7 months ago

If it's just your settings that are corrupted, you can try to delete some of the .ini's and have the game copy new ones from the default templates instead of reinstalling.

SAS_WIZ
Veteran
Veteran
Offline
Last seen: 5 months 4 weeks ago

yep
And if its another small file..get a friend to send you that individual file....saves loads of time.

SAS_WIZ

Spidey01
Offline
Last seen: 3 months 1 week ago

What alarms me is the Uninterruptible power supply (UPS) is generally supposed to keep power flowing for a period of time.

Although I'd reckon in the right circumstances a lighting strike could corrupt the computers memory enough for programs to crash, including Windows and RvS which could screw with the games files.

Rouge
Offline
Last seen: 8 years 9 months ago

Well ... I have reinstalled several times.

Read a medium-sized newspaper and drink a large cup of tea -- then you're done... Smile

SAS_CPT_Rouge

Cougar
Offline
Last seen: 3 years 1 month ago

I copied some key files to save redoing keyboard settings, etc and saves for campaigns.....uninstalled RvS and started to install....was promptly told I didn't have the right disk....oops. I'm usually very good at keeping my software where I can find it but in this case the origional two disc jewel case broke and they are in different jewel cases and disk 1 is AWOL. So, it may be a while before I'm back playing. I'll spend tommorow tearing up my room because it's undoubtably slipped behind/under something. Thanks for the suggestions.

IMAGE(http://miniprofile.xfire.com/bg/sh/type/0/slack911.png) aka Slack911, yamaraion, M827_CSM_COUGAR,Cougar]

Cougar
Offline
Last seen: 3 years 1 month ago

Sad Well, I am back to the problem I had about two years ago, when my RvS disk kept stopping at the same file and would not continue. Clearly it is a read CD problem and after a long time I tried again and it did load. Now I'm back to the install disk and the same problem is happening at the same file. So, having been "clever" I copied my saved map file over and then was able to finish the install. Then I booted the play disk and it started loading. After the movie I got a critical error but the problem is in the textures file and the error is:

OS: Windows XP 5.1 (Build: 2600)
CPU: GenuineIntel Unknown processor @ 2522 MHz with 1022MB RAM
Video: NVIDIA GeForce FX 5200 Ultra (6218)

Cannot load package ..\Textures\R6_Urban_Operations_T.utx: it was saved with version 323 (current version is 294)

History: FPackageFileSummary::VerifyPackageVersion

I tried removing that file:

R6_Urban_Operations_T.utx:

so it cheerfully went on to the next texture file it didn't like and gave error:

Cannot load package ..\Textures\Oil_T.utx: it was saved with version 297 (current version is 294)

I'm a bit confused at why I'm having this error not to mention dealing with it. I suspect some files dl online were upgrades and don't match the newly installed disk files. Perhaps the saved before uninstalling and copied Maps folder files are later versions than the texture files I didn't save before uninstall and installed from the install disk. I'm looking for an easy way around this. Any suggestions....before I start hacking away at my RvS files with a Hudson Bay axe technique?

:?

IMAGE(http://miniprofile.xfire.com/bg/sh/type/0/slack911.png) aka Slack911, yamaraion, M827_CSM_COUGAR,Cougar]

Spidey01
Offline
Last seen: 3 months 1 week ago

RvS files often use the R6 namespace for game files, your installation is probably corrupt.

A few map makers might use it as well but shouldn't do so in the same convention... not that anyone pays attention to correctness.

It is not wise to mix and match versions of files from the CD and a Patched install.

(if I've made any errors in my reading, please pardon it because I'm in hyper-speed mode! GTG eat before the dog steals my food >_>)

Cougar
Offline
Last seen: 3 years 1 month ago

I'm going to do a complete uninstall and start with a fresh folder. I only need to use the one map file "mountain_high" from the saved map folder to get the install to finish. I'll just have to redownload all my maps as I run into them. It's clearly using files I didn't delete and mucking up, not from the files I patched in after install. Likely my RvS Cache Utility is tripping me up. :roll:

IMAGE(http://miniprofile.xfire.com/bg/sh/type/0/slack911.png) aka Slack911, yamaraion, M827_CSM_COUGAR,Cougar]

Grishenko
Offline
Last seen: 8 years 7 months ago

Why don't you patch your installation before playing?

Cougar
Offline
Last seen: 3 years 1 month ago

The Patch has nothing to do with the problem I have. In fact I have successfully reinstalled the game from ground up....only using the one file that the CD won't read. What is wierd is that I am now again able to join games but I'm still having the problem, only in RvS, of being able to give commands like switch weapons and chat but no movement, not even leaning...just like before I started all this. Agggg :?

Oh, the UPS did just what it was supposed to do. It sensed a lightning strike and threw the circuit breakers to protect the hardware from damage. The rest of the house electricity worked fine, only the UPS supply shut down. If it hadn't........we wouldn't be having this conversation and I'd be picking shards of glass out of my face and clearing keyboard parts from between my teeth. Thanks for the suggestions so far and it's back to the drawing board.

IMAGE(http://miniprofile.xfire.com/bg/sh/type/0/slack911.png) aka Slack911, yamaraion, M827_CSM_COUGAR,Cougar]

Cougar
Offline
Last seen: 3 years 1 month ago

I'm beginning to suspect the problem is in the User file (configuration settings):

[DefaultPlayer]
CLASS=(null)
Name=Cougar(Apl)

[R6Menu.R6MenuMultiPlayerWidget]
m_iLastTabSel=1
m_iFilterFasterThan=350
m_bFilterDeathMatch=False
m_bFilterTeamDeathMatch=False
m_bFilterDisarmBomb=False
m_bFilterHostageRescueAdv=False
m_bFilterEscortPilot=False
m_bFilterMission=True
m_bFilterTerroristHunt=True
m_bFilterHostageRescueCoop=True
m_bFilterUnlockedOnly=False
m_bFilterFavoritesOnly=False
m_bFilterDedicatedServersOnly=False
m_bFilterServersNotEmpty=False
m_bFilterServersNotFull=False
m_bFilterResponding=False
m_bFilterSameVersion=False
m_bFilterPunkBusterServerOnly=False
m_szPopUpIP=

[Favorites]
favServer0=195.149.21.175:7777

[Engine.PlayerInput]
MouseSmoothingMode=1
MouseSensitivity=3.000000
MouseSamplingTime=0.011064
DoubleClickTime=0.250000

[Engine.R6GameOptions]
CharacterName=Cougar(Apl)
ArmorName=
PrimaryWeaponName=R6Description.R6DescAssaultG36K
PrimaryWeaponGadgetName=SILENCER
PrimaryBulletType=FMJ
SecondaryWeaponName=R6Description.R6DescPistolMk23
SecondaryWeaponGadgetName=CMAG
SecondaryBulletType=FMJ
FirstGadgetName=R6Description.R6DescFragGrenadeGadget
SecondGadgetName=R6Description.R6DescFragGrenadeGadget
AudioVirtual=eAV_None
NetSpeed=eNS_Cable
TextureDetail=eGL_Low
LightmapDetail=eGL_Low
RainbowsDetail=eGL_Medium
HostagesDetail=eGL_High
TerrosDetail=eGL_Low
RainbowsShadowLevel=eEL_Low
HostagesShadowLevel=eEL_None
TerrosShadowLevel=eEL_None
GoreLevel=eEL_High
DecalsDetail=eEL_Medium
AutoTargetSlider=0
AmbientVolume=70
VoicesVolume=100
MusicVolume=0
SndQuality=0
Gender=0
ChangeNameTime=60
R6ScreenSizeX=640
R6ScreenSizeY=480
R6ScreenRefreshRate=-1
SplashScreen=False
AlwaysRun=False
InvertMouse=False
Hide3DView=False
PopUpLoadPlan=True
PopUpQuickPlay=True
SndHardware=True
EAX=False
ActivePunkBuster=True
WantTriggerLag=False
HUDShowCharacterInfo=True
HUDShowCurrentTeamInfo=True
HUDShowOtherTeamInfo=True
HUDShowWeaponInfo=True
HUDShowFPWeapon=False
HUDShowReticule=True
HUDShowWaypointInfo=True
HUDShowActionIcon=True
HUDShowPlayersName=True
ShowRadar=True
AnimatedGeometry=False
HideDeadBodies=False
ShowRefreshRates=False
LowDetailSmoke=True
AllowChangeResInGame=False
AutoPatchDownload=False
CountDownDelayTime=0.000000
MouseSensitivity=20.799999
m_reticuleFriendColour=(B=0,G=255,R=0,A=0)
HUDMPColor=(B=239,G=209,R=129,A=75)
HUDMPDarkColor=(B=0,G=0,R=0,A=0)
MPAutoSelection=
ArmPatchTexture=GRENADE01.TGA

[Engine.Input]
OEMClear=
PA1=
NoName=
Zoom=
Play=
ErEof=
ExSel=
CrSel=
Attn=
UnknownF5=
UnknownF4=
UnknownF3=
UnknownF2=
UnknownF1=
UnknownF0=
Unknown10F=
Unknown10E=
MouseWheelDown=
MouseWheelUp=
UnknownEB=
UnknownEA=
JoyV=
JoyU=
MouseW=
MouseZ=
MouseY=
MouseX=
JoyR=
JoyZ=
JoyY=
JoyX=
UnknownDF=
SingleQuote=
RightBracket=
Backslash=
LeftBracket=
UnknownDA=
UnknownD9=
UnknownD8=
Joy16=
Joy15=
Joy14=
Joy13=
Joy12=
Joy11=
Joy10=
Joy9=
Joy8=
Joy7=
Joy6=
Joy5=
Joy4=
Joy3=
Joy2=
Joy1=
UnknownC7=
UnknownC6=
UnknownC5=
UnknownC4=
UnknownC3=
UnknownC2=
UnknownC1=
Tilde=Console
Slash=
Period=
Minus=MapZoomOut
Comma=
Equals=MapZoomIn
Semicolon=
UnknownB9=
UnknownB8=
UnknownB7=
UnknownB6=
UnknownB5=
UnknownB4=
UnknownB3=
UnknownB2=
UnknownB1=
UnknownB0=
UnknownAF=
UnknownAE=
UnknownAD=
UnknownAC=
UnknownAB=
UnknownAA=
UnknownA9=
UnknownA8=
UnknownA7=
UnknownA6=
UnknownA5=
UnknownA4=
RControl=
LControl=
RShift=
LShift=
Unknown9F=
Unknown9E=
Unknown9D=
Unknown9C=
Unknown9B=
Unknown9A=
Unknown99=
Unknown98=
Unknown97=
Unknown96=
Unknown95=
Unknown94=
Unknown93=
Unknown92=
ScrollLock=
NumLock=
Unknown8F=
Unknown8E=
Unknown8D=
Unknown8C=
Unknown8B=
Unknown8A=
Unknown89=
Unknown88=
F24=
F23=
F22=
F21=
F20=
F19=
F18=
F17=
F16=
F15=
F14=
F13=
F12=Shot
F11=
F10=
F9=
F8=
F7=
F6=
F5=
F4=DrawingTool
F3=VotingMenu
F2=ToggleAutoAim
F1=
GreySlash=PrimaryWeapon
NumPadPeriod=GadgetOne
GreyMinus=RaisePosture
Separator=
GreyPlus=LowerPosture
GreyStar=SecondaryWeapon
NumPad9=
NumPad8=MoveForward
NumPad7=Zoom
NumPad6=StrafeRight
NumPad5=FluidPosture
NumPad4=StrafeLeft
NumPad3=ChangeRateOfFire
NumPad2=MoveBackward
NumPad1=Reload
NumPad0=Action
Unknown5F=
Unknown5E=
Unknown5D=
Unknown5C=
Unknown5B=
Z=
Y=PreRecMessages
X=
W=GoCodeBravo
V=
U=TeamTalk
t=Talk
S=
R=GoCodeZulu
Q=GoCodeAlpha
P=
o=OperativeSelector
N=ToggleNightVision
M=ToggleMap
L=
k=
j=
i=InventoryMenu
H=ShowCompleteHud
G=
f=
E=GoCodeCharlie
D=
C=
B=
A=
Unknown40=
Unknown3F=
Unknown3E=
Unknown3D=
Unknown3C=
Unknown3B=
Unknown3A=
9=
8=
7=
6=
5=
4=
3=
2=
1=
0=
help=
Delete=GadgetTwo
Insert=
PrintScrn=
Execute=
Print=
Select=
Down=SpeedUpDoor
Right=GraduallyOpenDoor
Up=SecondaryFire
Left=GraduallyCloseDoor
home=ToggleAllTeamsHold
End=PeekLeft
PageDown=PeekRight
PageUp=NextMember
Space=
Unknown1F=
Unknown1E=
Unknown1D=
Unknown1C=
Escape=
Unknown1A=
Unknown19=
Unknown18=
Unknown17=
Unknown16=
Unknown15=
CapsLock=
Pause=
Alt=
Ctrl=ToggleSniperControl
Shift=
Unknown0F=
Unknown0E=
Enter=
Unknown0C=
Unknown0B=
Unknown0A=
Tab=ToggleGameStats
Backspace=RulesOfEngagement
Unknown07=
Unknown06=
Unknown05=
MiddleMouse=
Cancel=
RightMouse=Run
LeftMouse=PrimaryFire
StrProperty0=
Aliases[0]=(Command="",Alias="None")
Aliases[1]=(Command="",Alias="None")
Aliases[2]=(Command="",Alias="None")
Aliases[3]=(Command="",Alias="None")
Aliases[4]=(Command="",Alias="None")
Aliases[5]=(Command="",Alias="None")
Aliases[6]=(Command="",Alias="None")
Aliases[7]=(Command="",Alias="None")
Aliases[8]=(Command="",Alias="None")
Aliases[9]=(Command="",Alias="None")
Aliases[10]=(Command="",Alias="None")
Aliases[11]=(Command="",Alias="None")
Aliases[12]=(Command="",Alias="None")
Aliases[13]=(Command="",Alias="None")
Aliases[14]=(Command="",Alias="None")
Aliases[15]=(Command="",Alias="None")
Aliases[16]=(Command="",Alias="None")
Aliases[17]=(Command="",Alias="None")
Aliases[18]=(Command="",Alias="None")
Aliases[19]=(Command="",Alias="None")
Aliases[20]=(Command="",Alias="None")
Aliases[21]=(Command="",Alias="None")
Aliases[22]=(Command="",Alias="None")
Aliases[23]=(Command="",Alias="None")
Aliases[24]=(Command="",Alias="None")
Aliases[25]=(Command="",Alias="None")
Aliases[26]=(Command="",Alias="None")
Aliases[27]=(Command="",Alias="None")
Aliases[28]=(Command="",Alias="None")
Aliases[29]=(Command="",Alias="None")
Aliases[30]=(Command="",Alias="None")
Aliases[31]=(Command="",Alias="None")
Aliases[32]=(Command="",Alias="None")
Aliases[33]=(Command="",Alias="None")
Aliases[34]=(Command="",Alias="None")
Aliases[35]=(Command="",Alias="None")
Aliases[36]=(Command="",Alias="None")
Aliases[37]=(Command="",Alias="None")
Aliases[38]=(Command="",Alias="None")
Aliases[39]=(Command="",Alias="None")

[Engine.PlayerController]
EnemyTurnSpeed=45000
bLookUpStairs=False
bSnapToLevel=False
bAlwaysMouseLook=True
bKeyboardLook=True
MaxTimeMargin=1.000000
NetClientMaxTickRate=15.000000
ngWorldSecret=

[R6Menu.R6MenuDiffCustomMissionSelect]
CustomMissionDifficultyLevel=1

[R6Menu.R6MenuCustomMissionWidget]
CustomMissionGameType=1
CustomMissionMap=Alpines

I think somewhere in this file something is set wrong or not set. This is a copied file and not a new install so i guess ill remove it and reset.

IMAGE(http://miniprofile.xfire.com/bg/sh/type/0/slack911.png) aka Slack911, yamaraion, M827_CSM_COUGAR,Cougar]

Cougar
Offline
Last seen: 3 years 1 month ago

That was the problem. I hid the User file and then went to a custom mission and i got movement to standard keys w-a-s-d so I went to options and set controls. A new User file was created and the game works just fine.

LESSON:a sudden loss of normal keys/controls after a crash is likely to be the User file under Ravenshield/Save/profiles. I'd have to study the two side by side to find the problem, but what matters is that you do not have to reinstall, but hiding the User File and then resetting controls may be the "quick" fix.

Thanks again for all your suggestions. They were helpful I'm back online and will probably be around by early morning London time.

IMAGE(http://miniprofile.xfire.com/bg/sh/type/0/slack911.png) aka Slack911, yamaraion, M827_CSM_COUGAR,Cougar]

Ambu
Offline
Last seen: 8 years 10 months ago

Good to hear.

Ambu

Spidey01
Offline
Last seen: 3 months 1 week ago

Oh, the UPS did just what it was supposed to do. It sensed a lightning strike and threw the circuit breakers to protect the hardware from damage. The rest of the house electricity worked fine, only the UPS supply shut down.

An Uninterruptible Power Supply (UPS) is called Uninterruptible because it is supposed to be Uninterruptible Smile

The main difference between a UPS and a backup generator is when the main power conks out, the UPS will keep things powered. When the power level is to low or null, the UPS provides power from it's own source. While the generator engages (manually or automatically) after power has been cut out.

A surge protector is a device that will detect sudden spikes in the amount of power or some times just a change in the amount going through the line and divert it. either by flipping a short-circuit or sending it down a different vector then your connected hardware.

A UPS looks like one of these (the one on the right).

I remember at work, one of our old clients had a UPS from his job (IT) and his wife asked me to move the UPS from the living room to the office..... I could barely push the thing across the floor, and I've had to pick up their bigger dogs (35-45lbs) without much problems lol.

It really made me glad I didn't spend $80 for one myself!