I can't connect to TG3, can anyone help?

21 posts / 0 new
Last post
d0nk3y_k0n9
Offline
Last seen: 7 years 11 months ago
I can't connect to TG3, can anyone help?

I've been unable to connect to TG3 ever since i bought swat 4: TSS (about 4 days ago or so). Whenever i try, i get an error message and the game crashes. The worst part is, it then counts me as still on the server for about 1/2 an hour and will not let me connect because my CD key is still in use (or because i am the 8th person and its therefore full). I think ive managed to get onto the server 2 times, and it was empty both of them.

Is there anything i can do about this?

Any help would be appreciated.

Noer
Offline
Last seen: 8 years 1 month ago

I have also had that prob. Try it for a few more days, sometimes the server is weird.

And you write that you had access 2 times. So you can join = the game is working.

But I dont have a solution to your prob. The onle "way I know" is to reinstall the game.

SAS_Noer

Noer
Offline
Last seen: 8 years 1 month ago

Don. It just stroke me. If you have tried to join the server the last hour, then the prob might have been that the server have been restarted 2 or 3 times. In that process all get kicked from server.

SAS_Noer

d0nk3y_k0n9
Offline
Last seen: 7 years 11 months ago

I'm pretty sure that the problem with it isn't a problem with the server, as the game gets a critical error every time. Also, it has had critical errors at other random places in the game, but those critical errors tend to happen at the same places/times.

I'm considering just reinstalling.

Spidey01
Offline
Last seen: 3 months 3 days ago

Would probably be easier to reinstall then.

The installer should do integity checks, I hope lol...

SAS_Lazko
Veteran
Veteran
Offline
Last seen: 7 years 6 months ago

I often get that problem, and a reinstall fixes all that. I know its a pain but heh...

"Godo godo!" Lazko and his typoes image size exceeded -- click to view

d0nk3y_k0n9
Offline
Last seen: 7 years 11 months ago

Well, i just reinstalled, and i got the exact same error messages in the exact same places. SadSadSad

I also tried updating my video drivers, and that didn't help either.

Dragoon
Offline
Last seen: 7 years 5 months ago

i know that problem. I had it too, but sry mate i can't remember how to fix. but i wrote on what i do. I look it up if i found and than i tell you. Dragoon

Photo Sharing and Video Hosting at Photobucket

d0nk3y_k0n9
Offline
Last seen: 7 years 11 months ago

Ok first, I have to say that I absolutly HATE to resurrect a thread that has been dead this long... but I still have the problem and its really pissing me off. I so wanna play Swat4 with you guys but I can't. Sad

Anyway, the problem remains the same as before, but I've narrowed it down to the following:
-Single player works fine for both Swat4 normal and TSS
-Multiplayer works fine for joining servers for non-TSS
-Game experiences a critical error when joining a TSS server
-Game experiences the same error when attempting to so much as click on the host game button on either game

I've also talked to the game's tech support people via email, and all they gave me was the "This game hasn't been tested on Vista and it isn't recommended that you try to play on Vista" BS that basically says that they don't want to help me.

Thanks for your help, and if this thread has been dead too long and I shouldn't have done this, feel free to delete this post and let the thread fade back into obscurity.[/list]

SAS_DUKE
Veteran
Veteran
Offline
Last seen: 5 years 5 months ago

Hey, Donkey Kong!

Remembers me to the good times of Commodore C64... Lol

Feel free to post.

So, if you have trouble joining ANY TSS-server...

Has anyone VISTA running and his SWAT TSS is fine Question If yes, then it depends on the settings :idea:

What about your firewall-settings?

DUKE, Germany

"What's the plan?
Track'em, find'em, kill'em!"

SAS_WIZ
Veteran
Veteran
Offline
Last seen: 5 months 3 weeks ago

DK can you post your Cpu specifications here plz.

SAS_WIZ

Timbo
Offline
Last seen: 8 years 9 months ago

Vista is not the problem. Vista only buggs your game when playing......

You should check some things:

1. Do you have others programms running (like firewalls, virus-scanner)
2. Are you using ingame-communictaion software? (xfire...)
3. Also like Wiz wrote: hw spec

Disable all other programs and test it again.

If you are able, tell us exactly what error message you receive when kicked from the server.

Spidey01
Offline
Last seen: 3 months 3 days ago

They probably say that because the company essentially put SWAT4 and TSS on End Of Life before Vista was even out of the Beta cycle lol.

d0nk3y_k0n9
Offline
Last seen: 7 years 11 months ago

Well, I'm running an Intel Core 2 Duo 2.0Ghz, 2GB RAM, and Nvidia 7600 graphics card.

I don't have the error message right now, but I'll find it eventually. I'm not sure I want to post it because last time I tried to post an error message, the site thought I was trying to hack it. Sad

I have McAfee SecurityCenter and Windows Firewall. Windows Firewall is set to allow Swat 4 and TSS to pass through it, so that shouldn't be the problem. I'm sometimes running Xfire, sometimes not. I'll try disabling all other programs, but I'm not sure which processes it's safe to kill and which ones I can't touch without causing problems.

The main thing that's confusing me is that it seems to only crash for multiplayer-related reasons. I'm going to try uninstalling it, deleting all related files, including saved games, maps, configs, etc., and reinstalling it again to see if it works after a complete wipe.

EDIT: I also just realized that I don't know if I've tried to connect to any servers other than TG3. I don't think it'll work with any other server, but it can't hurt to try.

Woodlake
Offline
Last seen: 1 year 5 months ago

If you are gonna reinstall, be sure that you also clean your registry before you reinstall it.

go to start execute and type "regedit" now with F3 you can search for all that has to do with swat 4 and with sierra.

I suggest you delete all entrys found.
I also had to do this once myself, yes i also could not log on to online games. I also had to do it for a friend of mine..........and guess what!

IT WORKED, hehe

You can close your eyes for things you don't want to see, but you can't close your heart for things you don't want to feel

d0nk3y_k0n9
Offline
Last seen: 7 years 11 months ago

Ok, thanks for the tip. I'll probably try that tomorrow night or even today if I find time. If it works, I'll let you guys know and start playing on TG3 asap. If not, then hopefully something else does. Would you just search for "Swat" and delete all the registries it finds?

Spidey01
Offline
Last seen: 3 months 3 days ago

also remember to do the install sequence right.

e.g.

SWAT4
Make sure SWAT4 has a first run to generate files
SWAT4 Patch
May want to run game just in case

SWAT4:TSS

enjoy a MOD that got sold initially for $30 USD iirc Wink

Last time I ignored that sequence I got a FUBAR game of TSS crashing.

d0nk3y_k0n9
Offline
Last seen: 7 years 11 months ago

Okay, I reinstalled it and... it works!!! BiggrinBiggrinBiggrin

Thank you guys so much for your help! Now I have a new game to play around with, so I hope to be on TG3 as much as I can. I'll probably suck at first, but I tend to be a fast learner.

SAS_WIZ
Veteran
Veteran
Offline
Last seen: 5 months 3 weeks ago

hmm i notice 2 errors though that you might want to fix in your computer.

Get the Windows, and Intel dual core patches. The windows one can be found in our download section.

Also, you say that you are running Mcafee Suite. In that case you should turn off the windows firewall...Mcafee uses a firewall too, and it is much better. Never have more than 1 firewall running. Or you will struggle to join servers.

What you did by re-installing was, your firewall recognised the new application and allowed it, Im guessing that you installed Mcafee, After you installed SWAT the first time.

SAS_WIZ

d0nk3y_k0n9
Offline
Last seen: 7 years 11 months ago

What you say makes sense Wiz, but I have downloaded thoes patches (at least I think I did) and I definently installed McAfee before I installed any games. First thing I did when I got the computer actually, because I just don't trust myself to not do anything stupid on the internet. Also, I only have the virus and spyware scanning of McAfee installed, not the firewall, so Windows Firewall is my only Firewall.

I joined the server no problem tonight and played for a few rounds. I'm officially in love with Swat 4, and its so much better than RvS, although they both have their strong points.

SAS_DUKE
Veteran
Veteran
Offline
Last seen: 5 years 5 months ago

LolLolLol

You see, there is no need of influence by The Dark Side... Dirol

DUKE, Germany

"What's the plan?
Track'em, find'em, kill'em!"